Mengatasi IP Private Telkom Indihome

Selamat malam sobat semua. Pada kesempatan kali ini saya akan berbagi tips dan trik bagaimana caranya agar kita mendapatkan IP Publik dari Telkom Indihome. Kadang kala kita para mendapati IP Private Telkom, dimana IP tersebut tidak bisa kita akses dari luar jaringan. Terlebih lagi kita diharuskan menggunakan IP Publik tersebut untuk mengakses Aplikasi Web Server atau CCTV yang membutuhkan Direct IP (walaupun sekarang CCTV sudah memiliki fitur Cloud). 

Untuk mengatasi hal tersebut, kita bisa menambahkan script pada Mikrotik yang berfungsi agar ketika kita mendapatkan IP Dynamic dari Telkom IndiHome maka akan melakukan Redial atau Reconnecting kembali PPPoE sampai kita mendapatkan IP Publik, bukan IP Dynamic Private.

Brerikut Scriptnya.
/ppp profile
add change-tcp-mss=yes name=pppoe-with-check on-up="# Variables\r\
    \n:local currentLocalSiteInterface \"Nama-PPPoE-Anda\"\r\
    \n:local privateRanges {192.168.0.0/16; 172.16.0.0/12; 10.0.0.0/8} \r\
    \n:local loopCount 20\r\
    \n\r\
    \n# Script\r\
    \n:local hadMatch\r\
    \n:local currentLoop 0\r\
    \n\r\
    \n:if ([/interface pppoe-client get [/interface pppoe-client find name=\$currentLocalSiteInterface] running]) do={\r\
    \n   do {\r\
    \n      :set hadMatch false\r\
    \n      :local currentLocalSite [/ip address get [/ip address find interface=\$currentLocalSiteInterface] address]\r\
    \n      :local currentLocalSiteAddress ([:pick \$currentLocalSite 0 [:find \$currentLocalSite \"/\"]] & \\\r\
    \n         (255.255.255.255 << (32 - [:pick \$currentLocalSite ([:find \$currentLocalSite \"/\"] + 1) [:len \$currentLocalSite]]))) \r\
    \n         \r\
    \n      :foreach privateRange in=\$privateRanges do={ \r\
    \n         :if (([:pick \$privateRange 0 [:find \$privateRange \"/\"]] & \\\r\
    \n            (255.255.255.255 << (32 - [:pick \$privateRange ([:find \$privateRange \"/\"] + 1) [:len \$privateRange]]))) = \\\r\
    \n            (\$currentLocalSiteAddress & (255.255.255.255 << (32 - [:pick \$privateRange ([:find \$privateRange \"/\"] + 1) [:len \$privateRange]])))) do={ \r\
    \n                /interface disable \$currentLocalSiteInterface\r\
    \n                :delay 2\r\
    \n                /interface enable \$currentLocalSiteInterface\r\
    \n                :set hadMatch true\r\
    \n            :log error \"WAN IP address matched private IP address - \$privateRange\"\r\
    \n         } \r\
    \n      }\r\
    \n      :set currentLoop (\$currentLoop + 1)\r\
    \n  \r\
    \n      :if (\$hadMatch) do={\r\
    \n        :delay 2\r\
    \n      }\r\
    \n   } while ((\$currentLoop < \$loopCount) && (\$hadMatch))  \r\
    \n}"
Catatan : 
Paste kan script di atas pada menu System > Script lalu klik "+" . Untuk menyesuaikan Variabel interface , silahkan ganti variabel "Nama-PPPoE-Anda" sesuai dengan nama interface PPPoE Client di router  sobat semua.
Setelah disesuaikan variabel Interface PPPoE Client nya maka klik Apply lalu OK, Lalu langkah terahir klik Run Script

 Setelah sobat semua melakukan Run Script maka akan muncul Profile baru pada menu PPPoE Client , dan pilih profile tersebut
Muncul Profile baru pada PPPoE Client IndiHome Telkom
Saat mendaparkan IP Private telkom maka pada menu LOG akan muncul notifikasi seperti dibawah ini

Log saat mendaparkan IP Private Telkom IndiHome

Jika semua langkah diatas dilakukan dengan benar maka seharusnya sobat semua selalu mendapatkan IP Publik dengan awalan 36, 110, 180, 60, dan 118.

Oh iya satu lagi, Teknik diatas hanya bisa dilakukan pada posisi modem di Bridge, sehingga dial PPPoE dilakukan oleh router MikroTik.


Post a Comment

0 Comments